快好知 kuaihz订阅看过栏目大字版

 

 

超强MACD看透主力动向战法(附公式源码)

每一个成熟的操作者都有一套自己的交易系统,而对于大部分操作者来说,指标是一个完善的操作系统中必不可少的组成要素。很多人一提到指标就比较不屑,认为那是骗人的东西;有一些态度相对客观的人说,指标只是个参考的工具。而我想说:指标就好比一件兵器,好用与否更取决于自己的功力。它固然是个参考,但参考的前提是已经比较深刻的理解了指标的含义与特性,否则谈什么参考?还不如一味否定来的痛快! 对于MACD这个指标,相信大家并不会陌生,我之前也讲过MACD的完整攻略。不过,关于MACD金叉 的使用,仍经常被问到。今天,韩薇再次和大家聊聊到底要怎么用MACD金叉来交易。

MACD指标的一般研判标准主要是围绕快速和慢速两条均线及红、绿柱线状况和它们的形态展开。一般分析方法主要包括DIF指标和MACD值及它们所处的位置、DIF和MACD的交叉情况、红柱状的收缩情况和MACD图形的形态这四个大的方面分析。用红绿柱状来分析行情,既直观明了又实用可靠。

在实战中,我们发现不是每次macd金叉形成时都会迎来一波上涨的,如下图所形成的短线金叉,很多时候macd形成金叉以后,转眼就拐头死叉。或者,形成一段金叉股价出现滞涨,只要我们买入后它就开始形成死叉空头之势。

我习惯性的将这些逆涨甚至滞涨的金叉,视为假金叉。

就是因为这些假金叉,所以导致很多朋友宁愿大手笔花钱去买软件买指标,也不愿意再去使用这个最简单也是最实用的MACD指标

那么,我们该如何判断到底是真金叉还是假金叉?

我们来看下图

上图与第一张图一样,又是两个假金叉。这四个假金叉有何共同之处:

1、根据四个假金叉在MACD指标中所处的位置我们惊奇的发现,所有假金叉都在0轴线以下没有突破0轴。

2、根据金叉形成的先后顺序我们发现,每一个假金叉都是macd由0轴线上方下穿后形成的第一个金叉。

根据这个,我们可以得出一个结论,最容易形成买入与慎买的条件是:

Macd指标中0轴线以下的第一个金叉初期——坚决不买;

Macd指标中0轴线以下的第二个金叉初期——买入;

Macd指标中0轴线以上的第一个金叉初期——果断买入;

Macd指标中0轴线以上的第二个金叉初期——慎买;

这样我们就把握住了,什么样的金叉才能真正的对股价方向和买卖时机做出研判。

经典操盘法则:拒绝死叉和拒绝金叉

拒绝死叉”

(1)MACD“拒绝死叉”,就是DIFF指标在向上交叉DEA指标之后,保持向上运行的势头运行一段时间,然后突然转势向下运行,但是在即将向下穿越DEA指标时,又转头向上运行,导致形成“死叉”失败的走势形态。

(2)一般来说,在“拒绝死叉”出现后,股价都会向上运行,但是价格很少能够上涨到之前那样的高度。

(3)“拒绝死叉”是主力的洗盘手法之一,对于股民朋友来说,“拒绝死叉”是一种非常强烈的买进信号,当股民朋友发现MACD指标即将形成“死叉”的时候,就应该提高关注度,准备随时介入该股。

(4)最佳的买进时机是在MACD形成“拒绝死叉”反身向上的时候。

操作要点:

1、MACD在零轴上方出现拒绝死叉买入信号的时候,股价已经在60天均线上方运行,是强势的特征,可积极买入。尤其是在零轴上方第一次出现拒绝死叉买入信号时更应该积极买入。

2、MACD在零轴下方出现拒绝死叉买入信号时,股价仍然在60天均线下方运行,可先看作是反弹,先观望不适合介入。

七匹狼(股票代码:002029)在经过了一段底部横盘行情后,其MACD指标在2015年2月6日形成“拒绝死又”形态,此时的最高股价为9.88元。随后该股不断走高,直到4月7日,该股再次形成“拒绝死叉”形态,此时最高股价已经达到了15.71元,即使股民朋友这时就从容出局,那么也能吃到一段涨幅为59.01%的行情。当然,如果股民朋友想要使自己的利益最大化,也可以等到“拒绝死叉”形态循环被打破,在该股体现为形成“死叉”的时候再出局也是可以的(如图所示)。

拒绝金叉”

(1)MACD“拒绝金叉”就是DIFF指标在向下交叉DEA指标之后,保持向下运行的势头运行一段时间,然后突然转势向上运行,但是在即将向上穿越DEA指标时,又转头向下运行,导致形成“金叉”失败的走势形态。

(2)一般来说,“黄金交叉”是典型的买进信号,但是“拒绝金叉”却是典型的卖出信号。

(3)如果在“拒绝金叉”形成后,又形成了其他表示强烈买进的信号,那么股民朋友就可以考虑介入该股。

操作要点:

1、与拒绝死叉类似,拒绝金叉形态发生在零轴下方时,它所代表的下跌动能更强。

2、如果DIFF线逐渐向DEA线靠拢的同时成交量逐渐萎缩,是多方后续力量不足的信号。在这种情况下,该形态的抗跌信号会更加可靠。

中青宝(股票代码:300052)的MACD指标在2014年12月16日形成“拒绝死叉”形态,随后股价大幅下跌。直到2015年1月8日该股MACD指标又形成“金叉”,随后股价开始大幅上涨。如果股民朋友对“拒绝金叉”形态比较敏感,并且清楚地理解其含义,那么就能真正做到利用MACD指标来趋吉避凶,扩大自己的获利空间,增加自己的利润(如图所示)。

下面要讲的是MACD金叉出现拐点的选股公式,金叉出现后dif出现拐点,这是代表着在短期内调整一下 后,向上拉升的过程,后续的向上的趋势已经形成。具体来看一下条件要求:macd金叉后,不管上升多少天。只要找出第一次dif拐头向下的股票。

macd是证券系统自带的指标,只要输入名称后就会出现指标。查看里面的公式直接复制过来就行。具体公式如下:

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

金叉就是 dif上穿dea,具体公式为:

A1:=CROSS(DIF,DEA);

金叉之后上升的天数

统计天数用到了Bagslast函数,具体公式为:

A2:=BARSLAST(A1);

dif第一次拐点

dif第一次拐点是今天的值小于昨天的值,昨天的 值大于前天的值,这样就很直接的显示出现了拐点,具体的 公式为:

A3:=DIFREF(DIF,2);

因为是第一次拐点出现就选出,后面的拐点就不再需要选出,所以用到了COUNT函数,让统计出来的状况出现1次。

具体完整的公式为:

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

A1:=CROSS(DIF,DEA);

A2:=BARSLAST(A1);

A3:=DIFREF(DIF,2);

COUNT(A3,A2)=1 AND A3;

当大家是用的短线操作方式,可以考虑这个选股指标,在dif第一次拐点出现的时候买入,拿着筹码静等上升趋势形成,后面的行情是有一波收益的。

超强“MACD看透主力”战法

“MACD看穿主力”口诀:

1、底背离、低位金叉、二次金叉,还有双金叉(低位金叉和二次金叉)、三全项(底背离、低位金叉和二次金叉);

2、增加主力做坐庄四部曲:主力吸筹、主力拉升、主力派送和主力砸盘,主力行为一目了然;

3、把DIF线做成可以变色的线,主升浪时是红色线,主跌浪时是绿色线;

4、柱体也可以做出更多的颜色,零轴以下的不说了,零轴以上的,细分为黄金柱表买入、红柱表持有、绿柱表卖出。

“MACD看穿主力”用法:

1、主力拉升、底背离、低位金叉、二次金叉、双金叉和三全项,可以买入;

2、在0轴以上出红色MACD柱,主力拉升=1,建议持有;

3、在0轴以上出绿色MACD柱,主力拉升=0,坚决卖出。

实战分析:

超强MACD代码:

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);

OBV2:=EMA(OBV1,3)-MA(OBV1,9);

OBV3:=EMA(IF(OBV2>0,OBV2,0),3);

MAC3:=MA(C,3);

SHORT:=12;LONG:=26;MID:=9;

DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)COLORYELLOW ;

DEA:EMA(DIF,MID)COLORFF9900 ;

MACD:=(DIF-DEA)*2;

STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,2,0),COLORYELLOW;

吸:=XLPL.NOTEXT吸;

拉:=XLPL.NOTEXT拉;

派:=XLPL.NOTEXT派;

落:=XLPL.NOTEXT落;

STICKLINE(吸,0,MACD,1,0),COLORLIRED;

STICKLINE(拉,0,MACD,1,0),COLORRED;

STICKLINE(派,0,MACD,1,0),COLORGREEN;

STICKLINE(落,0,MACD,1,0),COLORWHITE;

入1:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;

入2:IF(DIF

低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;

STICKLINE(低位金叉,0,0.08,6,0),COLORFF00FF;

DRAWTEXT(低位金叉,0.16," 低位金叉"),COLORWHITE;

JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二次金叉,0,0.06,6,0),COLORFFCC00;

DRAWICON(二次金叉,DEA*0.9,1) ;

DRAWTEXT(二次金叉,0.2," 二次金叉"),COLORYELLOW;

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

底背离:=REF(CLOSE,A1 1)>CLOSE AND DIF>REF(DIF,A1 1) AND CROSS(DIF,DEA);

STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;

DRAWTEXT(底背离,0.12," 底背离"),COLORFF00FF;

A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

顶背离:=REF(CLOSE,A2 1)DIF AND CROSS(DEA,DIF);

DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,"三全项"),COLOR0000FF,LINETHICK2;DRAWTEXT_FIX(C>O,0.01,0.9,0," WWW.CXH99.COM "),COLORRED;

DRAWTEXT_FIX(C>O,1,1,0,"程序化交易模型"),COLORRED;

DRAWTEXT_FIX(C>O,0.01,0.9,0," WWW.CXH99.COM "),COLORRED;

DRAWTEXT_FIX(C>O,1,1,0,"程序化交易模型"),COLORRED;

最后再给大家说明一下运用MACD的时候需要注意的其它事项:

运用MACD指标能研判中长期走势,较易判断上涨或下跌行情的开始和技术、能判断出目前属于多头市场还是空头市场,避免逆向操作、根据指标采取相应的交易策略,降低无谓的频繁进出。

但是,MACD指标也存在它的不足。其不足之处在于当股价在短时间内上下波动较大时,由于MACD指标的反映相对迟缓,不能迅速产生交易信号,并不适用于短线操作。当股价波动幅度较小时,MACD指标发出的交易信号也不明显,不利于分析价格变动较少的个股。

【韩薇近期整理了一些学习资料,其中包括《主力操盘手法揭秘(高清)》、《发现庄股秘密,防止中招》、《资金流派1.1》等学习资料,想免费领取学习的股友可以加微信:sylg899,快速解决你的选股、买卖点、跟庄、看盘问题!】

搜索建议:超强MACD看透主力动向战法  战法  战法词条  动向  动向词条  看透  看透词条  公式  公式词条  源码  源码词条  
股票

 MACD六大功能及4不进场

原文地址:MACD六大功能及4不进场作者:包大人 (1)当一波下跌行情刚开始时,如股指出现反弹(K线出现阳线,而MACD继续缩短),就是给投资者第二次...(展开)

股票

 让我的收益爆发式增长的核心武器

不知不觉中认知篇已经分享了三期了,真的没有想到能得到这么多兄们的认可,鄙人的一些经历和拙见能给到大家启发特别的高兴,感恩有你们。同时我也观察到少数的朋友对认知还...(展开)