快好知 kuaihz订阅看过栏目大字版

 

 

修改两个公式,使它们的胜率都提高了

大盘好,指标的胜率也高了。

今天试着修改一个指标,看它的胜率会不会提高。

《通达信“超短”指标公式和选股公式——指标分享,胜率47.81%》

如图

信号只有一种,但出现太频繁,我试着把黄圈内的信号隐去,只选出红圈内的信号,选股公式如下:

P1:=(5); P2:=(4);

VAR1:=LLV(LOW,P1);

VAR2:=HHV(HIGH,P1);

短:=EMA((CLOSE-VAR1)/(VAR2-VAR1)*100,P2),COLORFF00FF,COLORRED;

线:=EMA(0.667*REF(短,1)+0.333*短,2);

买入参考:=CROSS(短,线);

卖出参考:=CROSS(线,短);

买入参考 AND 短<20 AND 线<20;

测试一下,平仓规则是,不论盈亏,以持股5天后平仓为条件

胜率55.04%,一下子上升了很多。

同样地,修改一下另一个指标

《通达信“终极买入升级版”指标公式和选股公式——指标分享,胜率45.51%》

修改后的公式如下:

R4:=(2*C+H+L)/4;

R5:=LLV(L,94);

R6:=HHV(H,89);

快:=EMA((C-R5)/(R6-R5)*100,8),COLORWHITE;

慢:=EMA(0.667*REF(快,1)+0.333*快,10),COLORCYAN;

DF:=3;

N1:=12;

RSV:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;

RSV2:=EMA((CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100,2),COLORRED;

RSV1:=EMA(SMA((CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100,8,1),3),COLORYELLOW;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

KK:=SMA(RSV,3,1);

DD:=SMA(K,3,1);

N:=KK+DD;

CROSS(快,慢) AND EXIST(CROSS(N,50),10);

测试一下,平仓规则是,不论盈亏,以持股5天后平仓为条件

胜率48.07%,也提升了。

就是这样。

搜索建议:胜率  胜率词条  公式  公式词条  它们  它们词条  两个  两个词条  修改  修改词条  
股票

 周六专栏:借势板,顺势板/造势板

大家对这个词应该不陌生,借自然是借助的意思,势自然是势能的意思,咱们平时说的主要指超短的势,板自然是涨停板,也就是借助超短情绪势能的涨停板,有点试图在行情好的情...(展开)