快好知 kuaihz订阅看过栏目大字版

 

 

精准超前MACD指标 通达信 副图 MACD指标 无...

公式源码:

{精准超前MACD}

0,COLORGRAY;

DIF12:=(EMA(CLOSE,12)-EMA(CLOSE,26))/((EMA(CLOSE,12)+EMA(CLOSE,26))/2)*1000;

DEA12:=EMA(DIF12,9);

KDIF12:=3*(DIF12-DEA12);

KDEA12:=SMA(KDIF12,5,2);

微分DIF:=KDIF12*5,COLORWHITE,LINETHICK1;

微分DEA:=KDEA12*5,COLORYELLOW,LINETHICK1;

MACD2:2*(微分DIF-微分DEA),COLORBLACK;

MAMACD:=MA(MACD2,3),,COLORBLACK;

STICKLINE(MACD2>REF(MACD2,1) AND MACD2>0,0,MACD2,1,0),COLORRED;

STICKLINE(MACD2<=ref(macd2,1) and="""" macd2="""">0,0,MACD2,1,0),COLORYELLOW;

STICKLINE(MACD2<>

STICKLINE(MACD2>=REF(MACD2,1) AND MACD2<>

STICKLINE(MAMACD<1*ref(mamacd,1), macd2="""">

STICKLINE(MAMACD>1*REF(MAMACD,1), MAMACD, MACD2 , 3, 0),COLORLIRED;

微分DIF2:KDIF12*5,COLORRED,LINETHICK1;

微分DEA2:KDEA12*5,COLORMAGENTA,LINETHICK1;

NOTEXT强:IF(微分DIF2<>

NOTEXT弱:IF(微分DEA2<>

{普通MACD}

DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*300,COLORWHITE,DOTLINE;

DEA:=EMA(DIF,9),COLORYELLOW,DOTLINE;

{------背离--------}

DIF普:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA普:=EMA(DIF,9);

MACD:=(DIF普-DEA普)*2,COLORSTICK;

A1:=BARSLAST(REF(CROSS(""MACD.DIF"",""MACD.DEA""),1));

B1:=REF(C,A1+1)>C AND REF(""MACD.DIF"",A1+1)<""macd.dif"" and="""">

{DRAWTEXT(B1>0,DIF*0.7,""↙MACD底背""),COLORFF00FF; }

C1:=BARSLAST(REF(CROSS(""MACD.DEA"",""MACD.DIF""),1));

D1:=REF(C,C1+1)""MACD.DIF"" AND CROSS(""MACD.DEA"",""MACD.DIF"");

{DRAWTEXT(D1>0,DIF*1.2,""↙MACD顶离""),COLORBLUE;}{MACD顶背离}

JC := DEA-DIF;

绿柱面积:=IF(MACD<><>

红柱面积:=IF(MACD>0,SUM(MACD,BARSLAST(JC>0)),0);

本次最低价:=LLV(L,BARSLAST(JC<>

本次最高价:=HHV(H,BARSLAST(JC>0));

X1:=IF (MACD<>

前次绿柱面积:=REF(绿柱面积,X1+1);

前次最低价:=REF(本次最低价,X1+1);

Y1:=IF((绿柱面积<0 and=""""><>

AND 本次最低价<前次最低价>

RS1:= MACD<0 and=""""><0 and=""""><>

AND ABS(绿柱面积)<>

底背驰: IF (CROSS(DIF,DEA),REF(Y1,1),0);

DRAWTEXT(底背驰,DIF*0.8,""↙积底背""),COLOR00FFFF;

X2:=IF (MACD>0,BARSLAST(CROSS(DEA,DIF)),0);

前次红柱面积:=REF(红柱面积,X2+1);

前次最高价:=REF(本次最高价,X2+1);

Y2:=IF((红柱面积>0 AND 红柱面积<前次红柱面积 and="""">前次最高价 ),1,0);

RS2:= MACD>0 AND REF(MACD,1)>0 AND C>前次最高价 AND ABS(红柱面积)<>

顶背驰:= IF (CROSS(DEA,DIF),REF(Y2,1),0);

DRAWTEXT(顶背驰,DIF*0.8,""↙顶底背""),COLORGREEN;

MACD高:=HHV(MACD,5);

E:=REF(C,C1+1)>C AND DEA>0 AND REF(MACD高,C1+1)

{DRAWTEXT(E>0,DIF*1.1,""↙柱顶背""),COLORRED;}

F:=REF(C,A1+1)>C AND DEA<0 and="""">

{DRAWTEXT(F>0,DIF*0.9,""↙柱底背""),COLORYELLOW;};

DRAWTEXT_FIX(C>O,0.01,0.9,0,""微信订阅号:翔博软件工作室""),COLOR556699;

=========================

搜索建议:指标  指标词条  MACD  MACD词条  精准  精准词条  超前  超前词条  通达  通达词条