快好知 kuaihz订阅看过栏目大字版

 

 

通达信20个抄底指标公式

来源:Internet,编辑:股旁网,2019-02-08

250,COLORWHITE,LINETHICK4;

{1.高春牛组合90%--信号少}

CAR1:=VOL<MA(VOL,5) AND MA(VOL,5)<MA(VOL,55);

CAR2:=CLOSE/REF(CLOSE,1)>1.028;

CAR3:=MA(CLOSE,10)>CLOSE*1.05;

CAR4:=MA(CLOSE,10)<CLOSE*1.1;

CAR5:=MA(CLOSE,60)>CLOSE*1.28;

金牛:=CAR1 AND CAR2 AND CAR3 AND CAR4 AND CAR5;

DIF1:=(CLOSE-SMA(CLOSE,7,1))/SMA(CLOSE,7,1)*(-100);

DEA1:=REF(DIF1,1)>13 AND REF(DIF1,1)/DIF1>1.3 AND CLOSE/REF(CLOSE,1)>1.03;

KOV:=IF(DEA1 AND REF(CLOSE,1)<=COST(5),28,0);

PIC:=IF(DEA1 AND REF(CLOSE,1)<=COST(5),18,0);

春笋:=IF(DEA1 AND REF(CLOSE,1)<=COST(5),1,0) AND C<MA(C,60);

VAR2:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

VAR3:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

VAR5:=(VAR2+2*VAR3+3*VAR4)/6;

VAR6:=MA(VAR5,3);

D02:=VAR6<=-10;

VAR11:=CLOSE/MA(CLOSE,30)*100<75;

VAR12:=CLOSE/MA(CLOSE,50)*100<78;

VAR13:=CLOSE/MA(CLOSE,70)*100<72;

VAR14:=HIGH>LOW*1.053;

VAR15:=VAR14 AND COUNT(VAR14,5)>2;

VAR16:=(VAR11 AND VAR12) OR (VAR12 AND VAR13) OR (VAR11 AND VAR13);

D4:=VAR15 AND VAR16;

高精:=D02 AND COUNT(D4,3)>=1;

高春牛组合:金牛 AND 春笋 AND 高精,COLORLIMAGENTA;

STICKLINE(高春牛组合,0,210,3,0),COLORLIMAGENTA;

DRAWTEXT(高春牛组合,210,"↙高春牛组合90%"),COLORLIMAGENTA;

{2明道88%}

AAA:=(C-MA(C,90))/MA(C,90)*100;

BBB:=(COST(11)-CLOSE)/CLOSE>0.15;

明道:CROSS(AAA,-26) AND BBB,COLOR00F5C2;

STICKLINE(明道,0,200,3,0),COLOR00F5C2;

DRAWTEXT(明道,200,"↙明道88%"),COLOR00F5C2;

{3赢一波组合84%}

BIAS0:=(C-MA(C,2))/MA(C,2)*100;

HXL:=V/CAPITAL*100;

D1:=INDEXC;

D2:=MA(D1,13);

DR2:=D2>1.040*D1;

E1:=(C-HHV(C,12))/HHV(C,12)*10;

E2:=(C-REF(C,26))/REF(C,26)*10;

E3:=MA(C,3);

SJ1:=DR2;

SJ2:=E2<-2.30;

SJ3:=BIAS0<-2.7;

SJ5:=SJ1 AND SJ2 AND SJ3;

一:=CROSS(0.5,SJ5);

C1X:=((MA(C,30)-L)/MA(C,60))*200;

M1X:=REF(CLOSE,1);

M2X:=SMA(MAX(CLOSE-M1X,0),7,1)/SMA(ABS(CLOSE-M1X),7,1)*100;

G1X:=FILTER(REF(M2X,1)<20 and="" m2x="">REF(M2X,1),5);

TUX:=C/MA(C,40)<0.74;

TDJX:=(H-L)/REF(C,1)>0.05;

YULX:=COUNT(TDJX,5)>1;

启动X:=TUX AND TDJX AND YULX;

波:=FILTER((G1X AND C1X>20 OR C>REF(C,1)) AND REF(启动X,1),10);

ETG1:=CLOSE/MA(CLOSE,30)*100<75;

ETG2:=CLOSE/MA(CLOSE,50)*100<78;

ETG3:=HIGH>LOW*1.053;

ETG4:=ETG3 AND COUNT(ETG3,5)>2;

ETG5:=ETG4 AND (ETG1 OR ETG2);

ETG6:=DMA(EMA(CLOSE,5),SUM(VOL,8)/2.8/CAPITAL);

ETG7:=(CLOSE-ETG6)/ETG6*100;

赢:=REF(ETG7,1)<-34 and="" etg7="">REF(ETG7,1) AND REF(ETG7,1)<REF(ETG7,2)

AND ETG7-REF(ETG7,1)>1.76 OR ETG5;

赢一波组合:赢 AND 一 AND 波,COLOR2A2AA3;

STICKLINE(赢一波组合,0,190,3,0),COLOR2A2AA3;

DRAWTEXT(赢一波组合,190,"↙赢一波组合84%"),COLOR2A2AA3;

{4率土之滨-85%信号较少}

X01:=MA(C,10)/C>1.055;

X02:=MA(C,10)/C<1.1;

X03:=MA(C,60)/C>1.28;

X04:=C/REF(C,1)>1.028;

X05:=H>L*1.05 AND COUNT(H>L*1.05,5)>3;

X06:=O/HHV(C,30)<0.78;

X07:=V<MA(V,5) AND MA(V,5)<MA(V,55);

X08:=O=LLV(O,30);

率土之滨:X01 AND X02 AND X03 AND X04 AND X05 AND X06 AND X07 AND X08,COLORFFFFAA;

STICKLINE(率土之滨,0,180,3,0),COLORFFFFAA;

DRAWTEXT(率土之滨,180,"↙率土之滨84%"),COLORFFFFAA;

{5钻石底-87%}

VBR:=C<REF(C,4);

NT0:=BARSLASTCOUNT(VBR);

TJ21:=NT0=6 ;

底6:=COUNT(NT0=6,5)=1;

VBR1:=DMA(CLOSE,VOL/SUM(VOL,34));

VBR2:=DMA(CLOSE,VOL/SUM(VOL,13));

VBR3:=(CLOSE-VBR1)/VBR1*100;

VBR4:=(CLOSE-VBR2)/VBR2*100;

Y1:=VBR4<=-17 AND VBR3<=-25;

去除ST:=IF(NAMELIKE("ST") OR NAMELIKE("*ST"),0,1);

去除停牌:=DYNAINFO(4)>0;

去除:=去除ST AND 去除停牌;

Q1:=底6 AND Y1 AND 去除;

超卖区:=MA((CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 ,2);

Q2:=超卖区<-20;

钻石底:Q1 AND Q2 AND C>REF(C,1)*0.91 AND C<REF(C,1)

AND INDEXCREF(C,1),1),COLOR0033FF;

STICKLINE(钻石底,0,170,3,0),COLOR0033FF;

DRAWTEXT(钻石底,170,"↙☆☆钻石底87%"),COLOR0033FF;

{6金牛起步83%}

CAR0:=VOL<MA(VOL,5) AND MA(VOL,5)<MA(VOL,55);

CAR02:=CLOSE/REF(CLOSE,1)>1.028;

CAR03:=MA(CLOSE,10)>CLOSE*1.05;

CAR04:=MA(CLOSE,10)<CLOSE*1.1;

CAR05:=MA(CLOSE,60)>CLOSE*1.28;

金牛起步:CAR0 AND CAR02 AND CAR03 AND CAR04 AND CAR05,COLOR0060FF;

STICKLINE(金牛起步,0,160,3,0),COLORWHITE;

STICKLINE(金牛起步,0,160,3.2,0),COLOR555555;

STICKLINE(金牛起步,0,160,2.6,0),COLOR777777;

STICKLINE(金牛起步,0,160,1.9,0),COLOR999999;

STICKLINE(金牛起步,0,160,1.1,0),COLORCCCCCC;

STICKLINE(金牛起步,0,160,0.3,0),COLORCCDDBB;

DRAWTEXT(金牛起步,160,"↙金牛起步83%"),COLOR0060FF;

{7超跌选股80%}

AAA1:=BARSLASTCOUNT(C>REF(C,4));

高A:=( AAA1=1);

VAR1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*200

+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*300

+(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100)/6;

VAR02:=MA(VAR1,6);

VAR03:=(HHV(HIGH,60)-REF(C,1))/HHV(HIGH,60)>0.3 AND (HHV(HIGH,60)-REF(C,1))/HHV(HIGH,60)<0.4;

超跌选股:CROSS(VAR1,VAR02) AND VAR1<-8.5 AND VAR03 AND 高A;

STICKLINE(超跌选股,0,150,3,0),COLORBD4DB6;

DRAWTEXT(超跌选股,150,"↙超跌选股80% "),COLORBD4DB6;

{8锤头王-80%}

CD1:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.57;

CD2:=LOW/MIN(CLOSE,OPEN)<=0.97;

EMA9:=EMA(CLOSE,9);

XSLDN:=EMA(EMA9*0.86,5);

CD3:=C<=XSLDN;

CD4:=REF(C,1)/REF(XSLDN,1)<0.98;

锤头王:C/REF(C,1)>0.99 AND CD1 AND CD2 AND CD3 AND CD4,COLOR9F46B4;

STICKLINE(锤头王,0,140,3,0),COLOR9F46B4;

DRAWTEXT(锤头王,140,"↙80% "),COLOR9F46B4;

{9核心低点-81%}

X_01:=O/HHV(C,30)<0.78;

X_02:=C/MA(C,50)<0.78;

X_03:=O=LLV(O,30);

X_04:=C/SMA(C,13,1)-1;

X_05:=REF(X_04,1)<-0.13;

X_06:=REF(X_04,1)/X_04>1.1582;

X_07:=REF(C,1)<=COST(5);

X_08:=COUNT(H>L*1.05,5)>2;

核心低点:X_01 AND X_02 AND X_03 AND X_05 AND X_06 AND X_07 AND X_08,COLORLIGREEN;

STICKLINE(核心低点,0,130,3,0),COLORLIGREEN;

DRAWTEXT(核心低点,130,"↙核心低点81%"),COLORLIGREEN;

{10狗头金综75%}

BIAS01:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

BIAS02:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

BIAS03:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,11)*100;

老二:=IF(BIAS02<=-10,1,0);

DIF3:=EMA(CLOSE,12)-EMA(CLOSE,150);

DEA3:=EMA(DIF3,9);

MACD3:=(DIF3-DEA3)*2;

爆发:=MACD3<0 and="" macd3="">REF(MACD3 ,1) AND REF(MACD3 ,1)<REF(MACD3 ,2)

AND REF(MACD3 ,2)<REF(MACD3 ,3)

AND REF(MACD3 ,3)<REF(MACD3 ,4);

VVAR1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

VVAR2:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

VVAR3:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

VVAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

VVAR5:=(VAR2+2*VVAR3+3*VVAR4)/6;

VVAR6:=MA(VVAR5,3);

大底:=VVAR6<=-10;

VVAR11:=CLOSE/MA(CLOSE,20)*100<80;

VVAR12:=CLOSE/MA(CLOSE,40)*100<78;

VVAR13:=CLOSE/MA(CLOSE,60)*100<72;

VVAR14:=HIGH>LOW*1.051;

VVAR15:=VVAR14 AND COUNT(VVAR14,5)>1;

中底:=VVAR15 AND (VVAR11 OR VVAR12 OR VVAR13);

操盘:=EMA((CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);

跟风:=EMA((CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7);

见到曙光:=CROSS(操盘,跟风) AND 操盘<0 AND 跟风 <0;

趋势线1:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 ;

AAX:=((REF(趋势线1,1)<REF(趋势线1,2) AND 趋势线1<-30) 1="" and="">=REF(趋势线1,1)) OR (REF(CROSS(-30,趋势线1),1) AND CROSS(趋势线1,-30)) OR 趋势线1=-30;

砸盘:=IF(AAX,500,-30);

BBX:=((REF(趋势线1,1)<REF(趋势线1,2) AND 趋势线1<-20 1="" and="">-25) AND 趋势线1>=REF(趋势线1,1)) OR (REF(CROSS(-20,趋势线1),1) AND CROSS(趋势线1,-20));

XG:=BBX;

WW:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

MM:=DMA(CLOSE,WW);

通道4:=(1-7/100)*MM;

VAR84:=EXPMA(CLOSE,9);

LDN:=EXPMA(VAR84*0.86,5);

TYP:=(HIGH+LOW+CLOSE)/3;

CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

TTRR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),

ABS(REF(CLOSE,1)-LOW)),14);

HD:=HIGH-REF(HIGH,1);

LD:=REF(LOW,1)-LOW;

DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);

DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);

PDI:=DMP*100/TTRR;

MDI:=DMM*100/TTRR;

ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6);

买底:=C<=通道4 AND C<=LDN AND CCI<-100

AND ADX>=60 AND MDI >= PDI AND CLOSE>OPEN;

VAR82:=LLV(LOW,10);

VAR83:=HHV(HIGH,25);

能量:=EMA((CLOSE-VAR82)/(VAR83-VAR82)*4,4);

底:=0.2;

关注:=0.5;

红色箭头:=FILTER(CROSS(能量,关注),20);

XXG:=买底 OR 红色箭头;

AX:=SMA((CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*100,4,1);

BX:=SMA((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100,4,1);

MBX:=SMA((BX-50)*2,3,1)+SMA((AX-50)*2,3,1)/2;

狗头金:=MBX<-90;

狗头金综: 狗头金 AND COUNT(XG,5) AND COUNT(中底,3) AND NOT(COUNT(XXG,1)) AND NOT(COUNT(见到曙光,3)) AND COUNT(老二,3) AND 大底 AND 爆发,NODRAW,COLORFF7080;

STICKLINE(狗头金综,0,120,3,0),COLORFF7080;

DRAWTEXT(狗头金综,120,"↙☆☆狗头金75%"),COLORFF7080;

{11高精抄底75%}

DIF:=EMA(CLOSE,12)-EMA(CLOSE,150);

DEA:=EMA(DIF,9);

MACD:=(DIF-DEA)*2;

VAR7:=MACD<0 AND REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);

VAR8:=MACD<0 AND REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3);

VAR9:=MACD<0 AND REF(MACD,1)<REF(MACD,2);

VAR10:=VAR7 OR VAR8 OR VAR9;

D3:=VAR10;

VAR016:=(VAR11 AND VAR12) OR (VAR12 AND VAR13) OR (VAR11 AND VAR13);

D04:=VAR15 AND VAR16;

趋势线:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100;

AA:=((REF(趋势线,1)<REF(趋势线,2) AND 趋势线<-30) and="">=REF(趋势线,1)) OR (REF(CROSS(-30,趋势线),1) AND CROSS(趋势线,-30)) OR 趋势线=-30;

BB:=((REF(趋势线,1)<REF(趋势线,2) AND 趋势线<-20 and="">-25) AND 趋势线>=REF(趋势线,1)) OR (REF(CROSS(-20,趋势线),1) AND CROSS(趋势线,-20));

D5:=BB;

SHYY:=D2 AND D3 AND COUNT(D04,3)>=1 AND COUNT(D5,5)>=1;

高精抄底:BARSLASTCOUNT(SHYY)=1,COLORE55B35;

STICKLINE(高精抄底,0,110,3,0),COLORE55B35;

DRAWTEXT(高精抄底,110,"↙高精抄底75%"),COLORE55B35;

{12吉祥低吸75%}

VARR2:=(2*CLOSE+HIGH+LOW)/4;

VARR4:=LLV(LOW,5);

VARR5:=HHV(HIGH,4);

吉:=EMA((VARR2-VARR4)/(VARR5-VARR4)*100,4);

祥:=EMA(0.667*REF(吉,1)+0.333*吉,2);

获利比:=(WINNER(C*125/100)-WINNER(C))*100<7.5;

吉祥低吸:CROSS(吉,祥) AND 吉<30 AND 获利比,COLOR93CB3F;

STICKLINE(吉祥低吸,0,100,3,0),COLOR93CB3F;

DRAWTEXT(吉祥低吸,100,"↙高精抄底75%"),COLOR93CB3F;

{13抄底深套盘76%}

深套:WINNER(C)*100<10 AND (WINNER(C*1.25)-WINNER(C))*100<20

AND C/REF(C,1)>1.0138 AND V/REF(V,1)<1,COLOR802391;

STICKLINE(深套,0,100,3,0),COLOR802391;

DRAWTEXT(深套,100,"↙深套75%"),COLOR802391;

{14大红马75%}

VARR10:=EMA(WINNER(C)*70,3);

VAR20:=EMA((WINNER(C*1.1)-WINNER(C*0.9))*80,3);

VAR30:=C/MA(C,40)*100<76;

VAR40:=C/MA(C,60)*100<74;

VAR50:=H>L*1.051;

VAR60:=VAR50 AND COUNT(VAR50,5)>1;

VAR70:=(WINNER(C*125/100)-WINNER(C))*100<7.5;

VAR80:=1;

TZB:=-0.2*(VAR60 AND (VAR30 OR VAR40) AND VAR20<20 AND VARR10<20 AND VAR70 AND VAR80);

DHM:=TZB<0 AND REF(TZB,1)=0;

风险值:=EMA (100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3)<=10;

机会来临:=REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,30,0),1);

HJ_11:=CLOSE/MA(CLOSE,40);

HJ_12:=CLOSE/MA(CLOSE,60)*100<71;

大魔鬼:=CROSS(HJ_11,HJ_12) AND 风险值 AND 机会来临;

大红马:DHM OR 大魔鬼,COLOR3369FF;

STICKLINE(大红马,0,90,3,0),COLOR3369FF;

DRAWTEXT(大红马,90,"↙大红马75%"),COLOR3369FF;

{15逆市买入77%}

VAR31A:=DMA(CLOSE,VOL/MA(VOL,4)/4);

VAR32A:=DMA(CLOSE,VOL/MA(VOL,32)/32);

VAR31:=(CLOSE-VAR31A)/VAR31A*100<-8;

VAR32:=(VAR31A-VAR32A)/VAR32A*100<-21;

VAR33:=(OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.05;

VAR34:=COUNT(NOT(C=O),8)>=8;

逆市买入:VAR31 AND VAR32 AND VAR33 AND VAR34,COLOR588500;

STICKLINE(逆市买入,0,80,3,0),COLOR588500;

DRAWTEXT(逆市买入,80,"↙逆市买入77%"),COLOR588500;

{16短线黑马-76%}

VAR1C:=DMA(C,VOL/MA(VOL,4)/4);

VAR2C:=DMA(C,VOL/MA(VOL,33)/33);

VAR3C:=(C-VAR1C)/VAR1C*100<-11;

VAR4C:=(VAR1C-VAR2C)/VAR2C*100<-22.3;

VAR5C:=VAR3C AND VAR4C AND COUNT(C<>O,7);

VAR6C:=DMA(C,VOL/MA(VOL,3)/3);

VAR7C:=DMA(C,VOL/MA(VOL,33)/33);

VAR8C:=(C-VAR6C)/VAR6C*100<-5;

VAR9C:=(VAR6C-VAR7C)/VAR7C*100<-18;

VARDC:=VAR8C AND VAR9C AND (O-REF(C,1))/REF(C,1)>-0.05;

VAREC:=VARDC AND COUNT(VARDC,2)=1;

DXHM:=VAR5C OR VAREC;

趋势:=SMA(MAX(C-REF(C,1),0),8,1)/SMA(ABS(C-REF(C,1)),8,1);

HMA:=CROSS(趋势,0.15);

X_21:=(C-MA(C,25))/MA(C,45)*123;

BAME:=CROSS(X_21,(-25)) AND C>REF(C,1);

HJ_1:=C/MA(C,40);

HJ_2:=C/MA(C,60)*100<71;

MOGU:=CROSS(HJ_1,HJ_2);

短线黑马:(DXHM AND HMA) OR (BAME AND MOGU),COLORF7A186;

STICKLINE(短线黑马,0,70,3,0),COLORF7A186;

DRAWTEXT(短线黑马,70,"↙短线黑马77%"),COLORF7A186;

{17神剑出鞘-70%}

T1:=(INDEXC-MA(INDEXC,58))/MA(INDEXC,58)<-0.152;

T2:=(C-EMA(C,58))/EMA(C,58)<-0.19;

买1:=T2 AND T1;

T4:=(C-MA(C,2))/MA(C,2)*100;

T5:=INDEXC;

T6:=MA(T5,13);

T7:=T6>1.050*T5;

T8:=(C-REF(C,26))/REF(C,26)*10;

T9:=T7;

T10:=T8<-2.30;

T11:=T4<-2.7;

T12:=T9 AND T10 AND T11;

T13:=CROSS(0.5,T12);

T14:=CROSS(T13,0.5);

T15:=BARSLAST(T14=1);

T16:=T15<=5 AND C<REF(C,T15);

买2:=T13 OR T16;

T17:= (C-MA(C,2))/MA(C,2)*100;

T18:=INDEXC;

T19:=MA(T18,56);

T20:=T18/T19<0.94;

T21:=(C-REF(C,26))/REF(C,26)*10;

T22:=T20;

T23:=T21<-2.55;

T24:=T17<-2.7;

T25:=T22 AND T23 AND T24;

T26:=CROSS(0.5,T25);

T27:=CROSS(T26,0.5);

T28:=BARSLAST(T27=1);

T29:=T28<=5 AND C<1.02*REF(C,T28);

底4:=T26 OR T29;

T30:= (C-MA(C,2))/MA(C,2)*100;

T31:=INDEXC;

T32:=MA(T31,13);

T33:=T32>1.050*T31;

T34:=(C-REF(C,26))/REF(C,26)*10;

T35:=T33;

T36:=T34<-2.69;

T37:=T30<-3.09;

T38:=T35 AND T36 AND T37;

T39:=CROSS(0.5,T38);

T40:=CROSS(T39,0.5);

T41:=BARSLAST(T40=1);

T42:=T41<=5 AND C<REF(C,T41);

买3:=COUNT(T39 OR T42,4)=4;

T43:=EMA(((C*1.1-LLV(LOW,630))/(HHV(HIGH,630)-LLV(LOW,630))-(C*0.9-LLV(LOW,630))/(HHV(HIGH,630)-LLV(LOW,630)))*80,5);

T44:=INDEXC;

T45:=MA(T44,5);

T46:=MA(T44,20);

T47:=MA(T44,30);

T48:=T45>T44*1.03 AND T46>T44*1.13;

T49:=T48;

目标:=COUNT(T43<6 and="">=3;

新目标:=买3 OR 目标;

SHYY1:=IF(((COUNT(买1 AND 底4,6)=6 OR COUNT(买1 AND 买2,4)=4 OR COUNT(买2 AND 底4,5)=5) OR 新目标),1,0);

神剑出鞘:BARSLASTCOUNT(SHYY)=1,COLORFF0080;

STICKLINE(神剑出鞘,0,60,3,0),COLORFF0080;

DRAWTEXT(神剑出鞘,60,"↙神剑出鞘70%"),COLORFF0080;

{18成功抄底-77%}

AA1:=("999999$C"/REF("999999$C",20)-1)*100<-16 AND (C/REF(C,27)-1)*100<-35;

A96:=FILTER(AA,3);

VBR41:=1;

VAR013:=V/CAPITAL;

REC1:=REF(C,1);

VBR42:=IF(EMA(C,5)/EMA(EMA(C,9),16)<=0.85 and="" rec1="">0.905 AND C/REC1<1.05 AND VAR13*100<5,50,0);

VBR43:=(-100)*(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34))+100;

VBR44:=(-100)*(HHV(H,50)-C)/(HHV(H,50)-LLV(L,50))+100;

VBR45:=(-100)*(HHV(H,70)-C)/(HHV(H,70)-LLV(L,70))+100;

VBR46:=((C-MA(C,34))/MA(C,34)*100+10)*5;

VBR47:=((C-MA(C,50))/MA(C,50)*100+10)*5;

VBR48:=((C-MA(C,70))/MA(C,70)*100+10)*5;

VBR49:=(VBR43+VBR44+VBR45+VBR46+VBR47+VBR48)/6;VBR60:=EMA(VBR49,3);

VBR61:=ABS(VBR46-VBR48);

VBR62:=(VBR49+VBR61)/2;

VBR50:=IF(VBR62<0 and="" c="LLV(C,5)" rec1="">0.905 AND C/REC1<1.05 AND VAR13*100<5,-50,0);

VBR53:=REF(C,2)*0.865;

VBR54:=REF(C,13)*0.772;

VBR55:=MIN(VBR53,VBR54);

VBR56:=100*VAR013;

VBR58:=IF((C-VBR55)/C<0.03 AND SUM(VBR56,5)/5<1.8,1,0);

VBR59:=IF(VBR58>0 AND (VBR50<0 or="" vbr42="">0),100,0);

VBR1F:=MA(C,80)-MA(C,10)/2.5;

F98:=VBR59 AND C<VBR1F*VBR41;

UAR13:=EMA(SLOPE(C,3)*20+C,66)*1;

UAR14:=MA(C,80)-MA(C,10)/2.9;

DQR1:=MA(C,80)-MA(C,13)/3;

DQR2:=MA((C-DQR1)/DQR1,1);

DQR3:=EMA(DQR2,12)*0.7;

DQR4:=EMA(DQR2,3);

底部将成:=IF(LLV(DQR4-DQR3,12)>0,0,-3);

下降通道:=MA(C/2/(MA(C/2,30)*0.83),3)<1.045 and="" 0.8="">O;

ZAA1:=MA(C,18);

ZAA2:=(C-ZAA1)/ZAA1*100;

ZAA3:=MA(ZAA2,1);

ZAA4:=BARSLAST(CROSS(-10,ZAA3)=1);

信号滤:=IF(ZAA3<-10 and="" zaa4="">=5,ZAA3,0)*1;

DQSE:=(IF(WINNER(1.1*C)<0,0,WINNER(1.1*C))-IF(WINNER(0.9*C)<0,0,WINNER(0.9*C)))*100;

DQS16:=IF(DQSE<0,0,DQSE);

DQS17:=MA(C,35)-MA(C,5)/7;

异动:=PWINNER(10,DQS16)<0.5 AND C<DQS17;

C95:=CMA(V,5)/240 AND UAR13>REC1*1.08 AND UAR13<MA(UAR13,13)*1.91 AND 底部将成 AND 下降通道 AND 信号滤 AND 异动;

成功抄底:A96 OR F98 OR C95,COLOR62B18A;

STICKLINE(成功抄底,0,50,3,0),COLOR62B18A;

DRAWTEXT(成功抄底,50,"↙成功抄底77%"),COLOR62B18A;

{19MACD选股-77%}

MA5:=MA(C,5);

MA10:=MA(C,10);

MA15:=MA(C,15);

MA20:=MA(C,20);

MA30:=MA(C,30);

MA40:=MA(C,40);

MA60:=MA(C,60);

DIF2:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA2:=EMA(DIF2,9);

MACD2:=(DIF2-DEA2)*2;

上影线:=(H-MAX(C,O))/(MAX(C,O)-MIN(C,O));

下影线:=(MAX(C,O)-L)/(MAX(C,O)-MIN(C,O));

水上金叉:=REF(MACD2,3)=LLV(MACD2,10) AND REF(MACD2<0,3) and="" macd2="">REF(MACD2,1),2) AND CROSS(DIF2,DEA2) AND BETWEEN(HHV(MACD2,28)/ABS(LLV(MACD2,7)),0.5,1.8) AND

EVERY(DEA2>=0,50) AND NOT(REF((OMA5),2)) AND NOT(O=L) AND NOT(REF(O=L,2)) AND NOT(O>MA5 AND L<=MA5) AND NOT(REF(H=MA5,3)) AND REF(下影线<5.24,3)

AND NOT(REF(C=L,3)) AND V>REF(V,1)*1.51 AND NOT(C<O) AND NOT(REF(CROSS(MA15,MA10),2)) AND NOT(REF(LMA10 AND O>C,1)) AND NOT(REF(CROSS(MA10,MA5),2));

水下金叉:=REF(MACD2,3)=LLV(MACD2,11) AND REF(MACD2<0,3) and="" macd2="">REF(MACD2,1),2) AND CROSS(DIF2,DEA2) AND EVERY(DEA2<0,14) AND BETWEEN(V,MA(V,10)*0.662,MA(V,10)*0.75)

AND BETWEEN(HHV(MACD2,28)/ABS(LLV(MACD2,7)),0.8,1.9) AND NOT(CROSS(MA15,MA20)) AND NOT(C=O) AND NOT(REF(CROSS(MA20,MA10),3)) AND NOT(CROSS(MA20,MA10)) AND

NOT(H>MA10 AND CROSS(C,MA10)) AND NOT(H>MA20 AND LMA20 AND L<MA5,1)) AND NOT(REF(CROSS(MA20,MA10),2)) AND 下影线<15.99 AND

NOT(REF(CROSS(MA15,MA10),1)) AND NOT(O=L) AND REF(下影线<8.24,2) AND NOT(REF(L<MA5 AND CROSS(C,MA10),1)) AND REF(下影线<5.99,1);

金叉:=水上金叉 OR 水下金叉;

底0:=BETWEEN(LLV(MACD,30),-0.0002,-0.6) AND REF(CROSS(DIF,DEA) AND BETWEEN(V,MA(V,10)*0.35,MA(V,10)*0.75) ,3) AND CROSS(MA5,MA10) AND BETWEEN(V,REF(V,1)*0.6,REF(V,1)*1.2)

AND NOT(OMA30 AND C>MA20) AND NOT(L<MA5 AND LMA5) AND NOT(CROSS(MA15,MA30)) AND NOT(CROSS(MA20,MA30)) AND C>O AND 下影线<3.27

AND 上影线<7.74 and="" h="">MA20 AND OMA15) AND NOT(CROSS(MA5,MA30) AND CROSS(MA5,MA20) AND CROSS(MA5,MA15)) AND NOT(C>MA40 AND LMA30)

AND NOT(REF(CROSS(MA10,MA5) AND C>MA60 AND LREF(V,1)*2.22,1)) AND NOT(REF(C=O,3))

AND NOT(REF(CROSS(MA5,MA15),1)) ;

底1:=底0 AND NOT(REF(CROSS(MA20,MA10),3)) AND NOT(REF(CROSS(MA10,MA5),3)) AND NOT(REF(O>MA10 AND LMA5 AND C<O,2))

AND NOT(REF(H>MA20 AND O<MA15,1)) AND REF(下影线<22.99,1) AND NOT(REF(CROSS(C,MA10) AND CROSS(C,MA15),1)) AND REF(上影线<35.99,2);

MACD选股:金叉 OR 底1,COLORFF00FF;

STICKLINE(MACD选股,0,40,3,0),COLORFF00FF;

DRAWTEXT(MACD选股,40,"↙MACD选股77%"),COLORFF00FF;

{20大周期底部73%-满回塘}

L40:=MA(C,40);

L60:=MA(C,60);

VVAR01:=CLOSE/L40*100<78;

VVAR02:=CLOSE/L60*100<74;

VVAR03:=HIGH>(LOW*1.051);

VVAR04:=VAR03 AND COUNT(VAR03,5)>1;

VVAR05:=CLOSE/HHV(HIGH,BARSCOUNT(CLOSE>0))*100;

DJH:=IF((REF(C,13)-CLOSE)/REF(C,13)*100*VVAR02>15

AND SUM(VOL/CAPITAL,13)*100<18 AND VOL/CAPITAL*100<2.5

AND (REF(C,1)-CLOSE)/REF(C,1)*100<8 AND VVAR05<=50 AND VVAR04

AND (VVAR01 OR VVAR02),1,0);

大周期底部:FILTER(DJH,6)NODRAW,COLORLICYAN;

STICKLINE(大周期底部,0,30,3,0),COLORFF00FF;

DRAWTEXT(大周期底部,30,"↙大周期底部73%"),COLORFF00FF;

搜索建议:通达信20个抄底指标公式  抄底  抄底词条  通达  通达词条  公式  公式词条  指标  指标词条